aboutsummaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
authorCody Hiar <cody@hiar.ca>2022-06-05 13:47:31 -0600
committerCody Hiar <cody@hiar.ca>2022-06-05 13:47:31 -0600
commit164704220b09e0f18f8be918f9fde025355f0dcd (patch)
tree35bf069bdee8b3b992a5757b1d3726a31d780f76 /flake.nix
parentd134dd7d77ad55442bf9b5e4b62361e9fcf3e198 (diff)
Get a basic flake set up
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix42
1 files changed, 42 insertions, 0 deletions
diff --git a/flake.nix b/flake.nix
new file mode 100644
index 0000000..87fffd5
--- /dev/null
+++ b/flake.nix
@@ -0,0 +1,42 @@
+{
+ description = "My Completely Inelegant Neovim Flake";
+
+ inputs = {
+ nixpkgs.url = "nixpkgs/nixos-unstable";
+ };
+
+ outputs = { self, nixpkgs }:
+ let
+ system = "x86_64-linux";
+ pkgs = import nixpkgs {
+ inherit system;
+ overlays = [
+ (self: super: {
+ vale = super.callPackage ./nix/vale.nix { };
+ flake8-isort = super.python3Packages.callPackage ./nix/flake8-isort.nix { };
+ mypython = super.python3Packages.callPackage ./nix/mypython.nix { };
+ })
+ ];
+ };
+ in {
+ packages.${system}.neovimCH = with pkgs; symlinkJoin {
+ name = "neovim";
+ paths = [ pkgs.neovim ];
+ buildInputs = [ pkgs.makeWrapper ];
+ postBuild = with pkgs; ''
+ rm $out/bin/nvim
+ BINPATH=${lib.makeBinPath [
+ nodejs
+ mypython
+ pyright
+ vale
+ tree-sitter
+ nodePackages.bash-language-server
+ shellcheck
+ hadolint
+ ]}
+ makeWrapper ${neovim}/bin/nvim $out/bin/nvim --prefix PATH : $BINPATH
+ '';
+ };
+ };
+}