aboutsummaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
authorCody Hiar <cody@hiar.ca>2022-06-05 14:04:33 -0600
committerCody Hiar <cody@hiar.ca>2022-06-05 14:04:33 -0600
commite617bc9fbce26fdb7c1adaddcbcdff4e8d538aa3 (patch)
tree3884680f139b04a812e06f2edf977ed000a2f114 /flake.nix
parentc883d5955d00c2f1d55af2470728db872a191330 (diff)
Try adding a default app to run flake remotely
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix51
1 files changed, 29 insertions, 22 deletions
diff --git a/flake.nix b/flake.nix
index 5c9454c..032a44e 100644
--- a/flake.nix
+++ b/flake.nix
@@ -18,28 +18,35 @@
})
];
};
- in {
- packages.${system} = rec {
- default = neovimCH;
- neovimCH = with pkgs; symlinkJoin {
- name = "neovim";
- paths = [ pkgs.neovim ];
- buildInputs = [ pkgs.makeWrapper ];
- postBuild = with pkgs; ''
- rm $out/bin/nvim
- BINPATH=${lib.makeBinPath [
- nodejs
- mypython
- pyright
- vale
- tree-sitter
- nodePackages.bash-language-server
- shellcheck
- hadolint
- ]}
- makeWrapper ${neovim}/bin/nvim $out/bin/nvim --prefix PATH : $BINPATH
- '';
+ in rec {
+ apps.${system} = rec {
+ nvim = {
+ type = "app";
+ program = "${packages.${system}.default}/bin/nvim";
+ };
+ default = nvim;
+ };
+ packages.${system} = rec {
+ default = neovimCH;
+ neovimCH = with pkgs; symlinkJoin {
+ name = "neovim";
+ paths = [ pkgs.neovim ];
+ buildInputs = [ pkgs.makeWrapper ];
+ postBuild = with pkgs; ''
+ rm $out/bin/nvim
+ BINPATH=${lib.makeBinPath [
+ nodejs
+ mypython
+ pyright
+ vale
+ tree-sitter
+ nodePackages.bash-language-server
+ shellcheck
+ hadolint
+ ]}
+ makeWrapper ${neovim}/bin/nvim $out/bin/nvim --prefix PATH : $BINPATH
+ '';
+ };
};
- };
};
}