aboutsummaryrefslogtreecommitdiff
path: root/nix/mypython.nix
diff options
context:
space:
mode:
authorCody Hiar <cody@hiar.ca>2022-06-05 13:47:31 -0600
committerCody Hiar <cody@hiar.ca>2022-06-05 13:47:31 -0600
commit164704220b09e0f18f8be918f9fde025355f0dcd (patch)
tree35bf069bdee8b3b992a5757b1d3726a31d780f76 /nix/mypython.nix
parentd134dd7d77ad55442bf9b5e4b62361e9fcf3e198 (diff)
Get a basic flake set up
Diffstat (limited to 'nix/mypython.nix')
-rw-r--r--nix/mypython.nix13
1 files changed, 13 insertions, 0 deletions
diff --git a/nix/mypython.nix b/nix/mypython.nix
new file mode 100644
index 0000000..aa262d4
--- /dev/null
+++ b/nix/mypython.nix
@@ -0,0 +1,13 @@
+{ python3, flake8-isort }:
+
+let
+ my-python-packages = python-packages: with python-packages; [
+ jedi-language-server
+ flake8
+ flake8-isort
+ isort
+ black
+ ];
+ mypython = python3.withPackages my-python-packages;
+in
+mypython