diff options
Diffstat (limited to 'flake.nix')
-rw-r--r-- | flake.nix | 51 |
1 files changed, 29 insertions, 22 deletions
@@ -18,28 +18,35 @@ }) ]; }; - in { - packages.${system} = rec { - default = neovimCH; - neovimCH = with pkgs; symlinkJoin { - name = "neovim"; - paths = [ pkgs.neovim ]; - buildInputs = [ pkgs.makeWrapper ]; - postBuild = with pkgs; '' - rm $out/bin/nvim - BINPATH=${lib.makeBinPath [ - nodejs - mypython - pyright - vale - tree-sitter - nodePackages.bash-language-server - shellcheck - hadolint - ]} - makeWrapper ${neovim}/bin/nvim $out/bin/nvim --prefix PATH : $BINPATH - ''; + in rec { + apps.${system} = rec { + nvim = { + type = "app"; + program = "${packages.${system}.default}/bin/nvim"; + }; + default = nvim; + }; + packages.${system} = rec { + default = neovimCH; + neovimCH = with pkgs; symlinkJoin { + name = "neovim"; + paths = [ pkgs.neovim ]; + buildInputs = [ pkgs.makeWrapper ]; + postBuild = with pkgs; '' + rm $out/bin/nvim + BINPATH=${lib.makeBinPath [ + nodejs + mypython + pyright + vale + tree-sitter + nodePackages.bash-language-server + shellcheck + hadolint + ]} + makeWrapper ${neovim}/bin/nvim $out/bin/nvim --prefix PATH : $BINPATH + ''; + }; }; - }; }; } |