aboutsummaryrefslogtreecommitdiff
path: root/nix/flake8-isort.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nix/flake8-isort.nix')
-rw-r--r--nix/flake8-isort.nix11
1 files changed, 11 insertions, 0 deletions
diff --git a/nix/flake8-isort.nix b/nix/flake8-isort.nix
new file mode 100644
index 0000000..385e4f7
--- /dev/null
+++ b/nix/flake8-isort.nix
@@ -0,0 +1,11 @@
+{ buildPythonPackage, fetchPypi, python3Packages }:
+
+buildPythonPackage rec {
+ pname = "flake8-isort";
+ version = "4.1.1";
+ src = fetchPypi {
+ inherit pname version;
+ sha256 = "2BQwSrcObliFm8XD4iHi5ucclY5wBSOSAv7hnCT4Jxc=";
+ };
+ checkInputs = with python3Packages; [ flake8 isort pytest testfixtures ];
+}