aboutsummaryrefslogtreecommitdiff
path: root/nix/mypython.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nix/mypython.nix')
-rw-r--r--nix/mypython.nix13
1 files changed, 13 insertions, 0 deletions
diff --git a/nix/mypython.nix b/nix/mypython.nix
new file mode 100644
index 0000000..aa262d4
--- /dev/null
+++ b/nix/mypython.nix
@@ -0,0 +1,13 @@
+{ python3, flake8-isort }:
+
+let
+ my-python-packages = python-packages: with python-packages; [
+ jedi-language-server
+ flake8
+ flake8-isort
+ isort
+ black
+ ];
+ mypython = python3.withPackages my-python-packages;
+in
+mypython