aboutsummaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
authorCody Hiar <cody@hiar.ca>2023-03-13 10:44:49 -0600
committerCody Hiar <cody@hiar.ca>2023-03-13 10:44:49 -0600
commitf69fe236e09bd3d34975335b091142804001b4ab (patch)
tree389271d4cc1f6ac169a6a53a5924c4c1c8fc4fc5 /flake.nix
Initial commit
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix19
1 files changed, 19 insertions, 0 deletions
diff --git a/flake.nix b/flake.nix
new file mode 100644
index 0000000..c65d19c
--- /dev/null
+++ b/flake.nix
@@ -0,0 +1,19 @@
+{
+ description = "A very basic flake";
+
+ outputs = { self, nixpkgs }:
+ let
+ system = "x86_64-linux";
+ pkgs = import nixpkgs { inherit system; };
+ in {
+
+ devShells.x86_64-linux.default = pkgs.mkShell {
+ nativeBuildInputs = with pkgs;
+ let
+ mypython = pkgs.python3.withPackages
+ (packages: with packages; [ markdown beautifulsoup4 aiohttp ]);
+ in [ mypython ];
+ };
+
+ };
+}