summaryrefslogtreecommitdiff
path: root/Adafruit_Python_CharLCD/setup.py
diff options
context:
space:
mode:
authorCody Hiar <codyfh@gmail.com>2018-05-27 15:29:21 -0600
committerCody Hiar <codyfh@gmail.com>2018-05-27 15:29:21 -0600
commitceec171c42bd79f1762b971569e20ead656f4fd0 (patch)
tree1880be0b1cef9786be5bc818cbd50095cd797a6d /Adafruit_Python_CharLCD/setup.py
parent611a8b7be4331e4f8416c4d10a0be47a109b47e4 (diff)
Moving libs into separate own directory
Diffstat (limited to 'Adafruit_Python_CharLCD/setup.py')
-rw-r--r--Adafruit_Python_CharLCD/setup.py30
1 files changed, 0 insertions, 30 deletions
diff --git a/Adafruit_Python_CharLCD/setup.py b/Adafruit_Python_CharLCD/setup.py
deleted file mode 100644
index 5c82f48..0000000
--- a/Adafruit_Python_CharLCD/setup.py
+++ /dev/null
@@ -1,30 +0,0 @@
-try:
- # Try using ez_setup to install setuptools if not already installed.
- from ez_setup import use_setuptools
- use_setuptools()
-except ImportError:
- # Ignore import error and assume Python 3 which already has setuptools.
- pass
-
-from setuptools import setup, find_packages
-
-classifiers = ['Development Status :: 4 - Beta',
- 'Operating System :: POSIX :: Linux',
- 'License :: OSI Approved :: MIT License',
- 'Intended Audience :: Developers',
- 'Programming Language :: Python :: 2.7',
- 'Programming Language :: Python :: 3',
- 'Topic :: Software Development',
- 'Topic :: System :: Hardware']
-
-setup(name = 'Adafruit_CharLCD',
- version = '1.1.1',
- author = 'Tony DiCola',
- author_email = 'tdicola@adafruit.com',
- description = 'Library to drive character LCD display and plate.',
- license = 'MIT',
- classifiers = classifiers,
- url = 'https://github.com/adafruit/Adafruit_Python_CharLCD/',
- dependency_links = ['https://github.com/adafruit/Adafruit_Python_GPIO/tarball/master#egg=Adafruit-GPIO-0.4.0'],
- install_requires = ['Adafruit-GPIO>=0.4.0'],
- packages = find_packages())