summaryrefslogtreecommitdiff
path: root/Adafruit_Python_GPIO/setup.py
diff options
context:
space:
mode:
authorCody Hiar <codyfh@gmail.com>2018-05-27 15:29:21 -0600
committerCody Hiar <codyfh@gmail.com>2018-05-27 15:29:21 -0600
commitceec171c42bd79f1762b971569e20ead656f4fd0 (patch)
tree1880be0b1cef9786be5bc818cbd50095cd797a6d /Adafruit_Python_GPIO/setup.py
parent611a8b7be4331e4f8416c4d10a0be47a109b47e4 (diff)
Moving libs into separate own directory
Diffstat (limited to 'Adafruit_Python_GPIO/setup.py')
-rw-r--r--Adafruit_Python_GPIO/setup.py28
1 files changed, 0 insertions, 28 deletions
diff --git a/Adafruit_Python_GPIO/setup.py b/Adafruit_Python_GPIO/setup.py
deleted file mode 100644
index 592a34c..0000000
--- a/Adafruit_Python_GPIO/setup.py
+++ /dev/null
@@ -1,28 +0,0 @@
-try:
- # Try using ez_setup to install setuptools if not already installed.
- from ez_setup import use_setuptools
- use_setuptools()
-except ImportError:
- # Ignore import error and assume Python 3 which already has setuptools.
- pass
-
-from setuptools import setup, find_packages
-
-import sys
-
-# Define required packages.
-requires = ['adafruit-pureio']
-# Assume spidev is required on non-windows & non-mac platforms (i.e. linux).
-if sys.platform != 'win32' and sys.platform != 'darwin':
- requires.append('spidev')
-
-setup(name = 'Adafruit_GPIO',
- version = '1.0.3',
- author = 'Tony DiCola',
- author_email = 'tdicola@adafruit.com',
- description = 'Library to provide a cross-platform GPIO interface on the Raspberry Pi and Beaglebone Black using the RPi.GPIO and Adafruit_BBIO libraries.',
- license = 'MIT',
- url = 'https://github.com/adafruit/Adafruit_Python_GPIO/',
- install_requires = requires,
- test_suite = 'tests',
- packages = find_packages())