aboutsummaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
authorCody Hiar <cody@hiar.ca>2022-06-05 14:09:57 -0600
committerCody Hiar <cody@hiar.ca>2022-06-05 14:09:57 -0600
commitbcb4bcde2c81401ef795d568ff00dd57c09e17e7 (patch)
tree7b9002d3fef877e59dee6db2d8ad170c86d1d4f1 /flake.nix
parente617bc9fbce26fdb7c1adaddcbcdff4e8d538aa3 (diff)
Testing nix < 2.7 syntax
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix14
1 files changed, 5 insertions, 9 deletions
diff --git a/flake.nix b/flake.nix
index 032a44e..3931d4d 100644
--- a/flake.nix
+++ b/flake.nix
@@ -19,16 +19,12 @@
];
};
in rec {
- apps.${system} = rec {
- nvim = {
- type = "app";
- program = "${packages.${system}.default}/bin/nvim";
- };
- default = nvim;
+ # From nix >= 2.7 the default app syntax changes
+ defaultApp.${system} = {
+ type = "app";
+ program = "${packages.${system}.neovimCH}/bin/nvim";
};
- packages.${system} = rec {
- default = neovimCH;
- neovimCH = with pkgs; symlinkJoin {
+ packages.${system}.neovimCH = with pkgs; symlinkJoin {
name = "neovim";
paths = [ pkgs.neovim ];
buildInputs = [ pkgs.makeWrapper ];