summaryrefslogtreecommitdiff
path: root/Adafruit_Python_MCP3008/setup.py
diff options
context:
space:
mode:
authorCody Hiar <codyfh@gmail.com>2018-05-16 21:14:38 -0600
committerCody Hiar <codyfh@gmail.com>2018-05-16 21:14:38 -0600
commit611a8b7be4331e4f8416c4d10a0be47a109b47e4 (patch)
tree206adb073b1eeda504f05e9a81eabc416da961aa /Adafruit_Python_MCP3008/setup.py
parentcec86d65a5b80bcfaf447ff078031d92ed3c7557 (diff)
Adding MCP3008 library
Diffstat (limited to 'Adafruit_Python_MCP3008/setup.py')
-rw-r--r--Adafruit_Python_MCP3008/setup.py30
1 files changed, 30 insertions, 0 deletions
diff --git a/Adafruit_Python_MCP3008/setup.py b/Adafruit_Python_MCP3008/setup.py
new file mode 100644
index 0000000..31bda9c
--- /dev/null
+++ b/Adafruit_Python_MCP3008/setup.py
@@ -0,0 +1,30 @@
+try:
+ # Try using ez_setup to install setuptools if not already installed.
+ from ez_setup import use_setuptools
+ use_setuptools()
+except ImportError:
+ # Ignore import error and assume Python 3 which already has setuptools.
+ pass
+
+from setuptools import setup, find_packages
+
+classifiers = ['Development Status :: 4 - Beta',
+ 'Operating System :: POSIX :: Linux',
+ 'License :: OSI Approved :: MIT License',
+ 'Intended Audience :: Developers',
+ 'Programming Language :: Python :: 2.7',
+ 'Programming Language :: Python :: 3',
+ 'Topic :: Software Development',
+ 'Topic :: System :: Hardware']
+
+setup(name = 'Adafruit_MCP3008',
+ version = '1.0.2',
+ author = 'Tony DiCola',
+ author_email = 'tdicola@adafruit.com',
+ description = 'Python code to use the MCP3008 analog to digital converter with a Raspberry Pi or BeagleBone black.',
+ license = 'MIT',
+ classifiers = classifiers,
+ url = 'https://github.com/adafruit/Adafruit_Python_MCP3008/',
+ dependency_links = ['https://github.com/adafruit/Adafruit_Python_GPIO/tarball/master#egg=Adafruit-GPIO-0.6.5'],
+ install_requires = ['Adafruit-GPIO>=0.6.5'],
+ packages = find_packages())